Installation/ParaView/FAQ

From OpenFOAMWiki
< Installation‎ | ParaView
Revision as of 12:11, 28 December 2018 by Wyldckat (Talk | contribs)

1 Introduction

This page aims to collect answers for frequently asked questions how to build ParaView, when using OpenFOAM's own makeParaView script(s). Feel free to extend this page with more details.


2 Error message: "GL version 2.1 with the gpu_shader4 extension is not supported by your graphics driver"

Version
ParaView 5.0.0 and newer
Reason
This has a higher chance of occurring inside a virtual machine, rather than in a real machine. As of ParaView 5.0.0, using OpenGL2 has become the default and this version of OpenGL isn't fully supported by many graphics drivers that are used inside virtual machines... unless the 3D graphics acceleration feature is turned on and a few adjustments are made.
For more details about this feature, see the at Kitware's blog the post New OpenGL Rendering in VTK. It was already available as an optional build setting in ParaView 4.4.0.
Solution
The solution is to build ParaView with the option VTK_RENDERING_BACKEND=OpenGL, which can be done by running makeParaView with this additional option:
./makeParaView VTK_RENDERING_BACKEND=OpenGL
Or within the context of an existing installation instructions, for example installing OpenFOAM+ v1606+ in CentOS 6.7, this command:
./makeParaView -qmake $WM_THIRD_PARTY_DIR/platforms/$WM_ARCH$WM_COMPILER/qt-4.8.6/bin/qmake -mpi -python > log.makePV 2>&1
becomes this:
./makeParaView -qmake $WM_THIRD_PARTY_DIR/platforms/$WM_ARCH$WM_COMPILER/qt-4.8.6/bin/qmake -mpi -python VTK_RENDERING_BACKEND=OpenGL > log.makePV 2>&1

2.1 Alternative solution

In OpenFOAM 5 and 6, it's possible to use the option -rendering, for example:

./makeParaView -qmake $WM_THIRD_PARTY_DIR/platforms/$WM_ARCH$WM_COMPILER/qt-4.8.6/bin/qmake -mpi -python -rendering OpenGL > log.makePV 2>&1


3 Building ParaView and plug-ins without Qt

Version
ParaView 3.12.0
Instructions on how to build ParaView 3.12.0 and the official OpenFOAM 2.2 plug-ins for ParaView, are available at the CFD-Online OpenFOAM forum, here: OpenFOAM 2.2.2 on a server (no X) - post #7 to #9


4 Override the supported GCC versions

Version
ParaView 4.0 and newer, perhaps also older versions
If ParaView complains about an incompatible GCC version, you can try and override that as instructed on the following post at CFD-Online OpenFOAM forum: 3.0.x ParaView compiling error Fedora 24 - post #2